Fedora Linux Support Community & Resources Center

Go Back   FedoraForum.org > Other Versions > EOL (End Of Life) Versions
FedoraForum Search

Forgot Password? Join Us!

EOL (End Of Life) Versions This is a Forum to discuss problems and workarounds for versions of Fedora that have passed End of Life.

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 30th May 2015, 06:53 AM
Jagcoxa Offline
Registered User
 
Join Date: Apr 2013
Location: Europe / Netherlands
Age: 44
Posts: 264
linuxchrome
You don't have permission to access /phpmyadmin on this server [FC22 server]

from a headless server:

yum install phpmyadmin [enter]
confirm with y

afterwards:
server_ip/phpmyadmin in browser

states:
403 Forbidden

Forbidden

You don't have permission to access /phpmyadmin on this server.



thanks
__________________
Most statisfied user of Fedora Core in the Netherlands
Reply With Quote
  #2  
Old 30th May 2015, 10:53 AM
SteveGYBE's Avatar
SteveGYBE Offline
Registered User
 
Join Date: Jun 2007
Location: Lytham St Annes, Lancashire, UK
Posts: 687
linuxfedorafirefox
Re: You don't have permission to access /phpmyadmin on this server [FC22 server]

Out-of-the-box, phpMyAdmin is only accessible on the loopback address (120.0.0.1 / ::1) of the HTTP server where installed. You will need to edit /etc/httpd/conf.d/phpMyAdmin.conf and add a line allowing your remote IP addresses or subnets to access the various server directories remotely, e.g.
Code:
     <RequireAny>
       Require ip 127.0.0.1
       Require ip 102.168.0.0/24
     </RequireAny>
It does this initially as, without SSL/TLS, logging on will be sending your logon credentials across the network unencrypted. I avoid this by also adding the directive "SSLRequireSSL" in the directory stanza, which of course requires me to access it using "https://..."
Code:
<Directory /usr/share/phpMyAdmin/>
   AddDefaultCharset UTF-8
   SSLRequireSSL
   [ . . . ]
Reply With Quote
  #3  
Old 30th May 2015, 01:01 PM
Jagcoxa Offline
Registered User
 
Join Date: Apr 2013
Location: Europe / Netherlands
Age: 44
Posts: 264
linuxchrome
Re: You don't have permission to access /phpmyadmin on this server [FC22 server]

thankx

will work on that today
__________________
Most statisfied user of Fedora Core in the Netherlands
Reply With Quote
  #4  
Old 30th May 2015, 03:27 PM
Jagcoxa Offline
Registered User
 
Join Date: Apr 2013
Location: Europe / Netherlands
Age: 44
Posts: 264
linuxchrome
Re: You don't have permission to access /phpmyadmin on this server [FC22 server]

by adding the first 4 lines you gave me the httpd server refuses to restart
__________________
Most statisfied user of Fedora Core in the Netherlands
Reply With Quote
  #5  
Old 30th May 2015, 03:33 PM
SteveGYBE's Avatar
SteveGYBE Offline
Registered User
 
Join Date: Jun 2007
Location: Lytham St Annes, Lancashire, UK
Posts: 687
linuxfedorafirefox
Re: You don't have permission to access /phpmyadmin on this server [FC22 server]

You only need to add one line (similar to that in bold, but referencing your own network address or subnet) under the other "Require ip ..." lines in the existing "<RequireAny>" blocks.

Don't add a whole new block of four lines!
Reply With Quote
  #6  
Old 30th May 2015, 03:35 PM
Jagcoxa Offline
Registered User
 
Join Date: Apr 2013
Location: Europe / Netherlands
Age: 44
Posts: 264
linuxchrome
Re: You don't have permission to access /phpmyadmin on this server [FC22 server]

hi

added your lines directly below:

<Directory /usr/share/phpMyAdmin>
AddDefaultCharset UTF-8

these 3 directly below:
<RequireAny>
Require ip SERVERIP
</RequireAny>

and save, results in a working phpmyadmin webpage
__________________
Most statisfied user of Fedora Core in the Netherlands
Reply With Quote
  #7  
Old 30th May 2015, 03:47 PM
Jagcoxa Offline
Registered User
 
Join Date: Apr 2013
Location: Europe / Netherlands
Age: 44
Posts: 264
linuxchrome
Re: You don't have permission to access /phpmyadmin on this server [FC22 server]

and this trick works perfectly after the installation of owncloud

Thank you!!!!!!!!!!!
__________________
Most statisfied user of Fedora Core in the Netherlands
Reply With Quote
  #8  
Old 31st May 2015, 08:57 AM
Jagcoxa Offline
Registered User
 
Join Date: Apr 2013
Location: Europe / Netherlands
Age: 44
Posts: 264
linuxchrome
Re: You don't have permission to access /phpmyadmin on this server [FC22 server]

does not work

error gives:
Cannot log in to the MySQL server

i am working from putty, but ps aux | grep mariadb shows some result
__________________
Most statisfied user of Fedora Core in the Netherlands
Reply With Quote
  #9  
Old 31st May 2015, 09:29 AM
Jagcoxa Offline
Registered User
 
Join Date: Apr 2013
Location: Europe / Netherlands
Age: 44
Posts: 264
linuxchrome
Re: You don't have permission to access /phpmyadmin on this server [FC22 server]

Working!

open putty
obtain access to server

Code:
[root@www ~]# vi /etc/my.cnf
# add follows within [mysqld] section
[mysqld]
character-set-server=utf8
[root@www ~]# systemctl start mariadb 
[root@www ~]# systemctl enable mariadb
after that:

Code:
[root@www ~]# mysql_secure_installation 
/usr/bin/mysql_secure_installation: line 379: find_mysql_client: command not found

NOTE: RUNNING ALL PARTS OF THIS SCRIPT IS RECOMMENDED FOR ALL MariaDB
      SERVERS IN PRODUCTION USE!  PLEASE READ EACH STEP CAREFULLY!

In order to log into MariaDB to secure it, we'll need the current
password for the root user.  If you've just installed MariaDB, and
you haven't set the root password yet, the password will be blank,
so you should just press enter here.

Enter current password for root (enter for none):
OK, successfully used password, moving on...

Setting the root password ensures that nobody can log into the MariaDB
root user without the proper authorisation.

# set root password
Set root password? [Y/n] y
New password:
Re-enter new password:
Password updated successfully!
Reloading privilege tables..
 ... Success!

By default, a MariaDB installation has an anonymous user, allowing anyone
to log into MariaDB without having to have a user account created for
them.  This is intended only for testing, and to make the installation
go a bit smoother.  You should remove them before moving into a
production environment.
# remove anonymous users
Remove anonymous users? [Y/n] y
 ... Success!

Normally, root should only be allowed to connect from 'localhost'.  This
ensures that someone cannot guess at the root password from the network.

# disallow root login remotely
Disallow root login remotely? [Y/n] n PRESS N HERE, since you want remote access  
 ... Success!

By default, MariaDB comes with a database named 'test' that anyone can
access.  This is also intended only for testing, and should be removed
before moving into a production environment.

# remove test database
Remove test database and access to it? [Y/n] y
 - Dropping test database...
 ... Success!
 - Removing privileges on test database...
 ... Success!

Reloading the privilege tables will ensure that all changes made so far
will take effect immediately.

# reload privilege tables
Reload privilege tables now? [Y/n] y
 ... Success!

Cleaning up...

All done!  If you've completed all of the above steps, your MariaDB
installation should now be secure.

Thanks for using MariaDB!
working now, lovely
__________________
Most statisfied user of Fedora Core in the Netherlands
Reply With Quote
  #10  
Old 25th May 2017, 02:37 PM
rickhrkachjr Offline
Registered User
 
Join Date: May 2017
Location: United States
Posts: 2
linuxfedorafirefox
Re: You don't have permission to access /phpmyadmin on this server [FC22 server]

OK just so I understand the solution, by deleting the alias accounts, you were able to log in remotely?

Rick H.
Reply With Quote
  #11  
Old 25th May 2017, 03:14 PM
antikythera Offline
Administrator
 
Join Date: Dec 2013
Location: United Kingdom
Posts: 5,074
linuxfedorafirefox
Re: You don't have permission to access /phpmyadmin on this server [FC22 server]

I'll leave this one open just on the off-chance Jagcoxa answers but it's been a long time since they have been active here. Also, F22 is no longer supported by Fedora Project, so if you have a server running anything earlier than Fedora 24/25 consider an upgrade or switch to CentOS to continue receiving security and stability patches.

If you need help with anything and only find reference to your problem in a thread that has been dormant for near as dammit two years, feel free to start your own new one in future.
__________________
Download, Install and Share Fedora - Official ISO Torrents | Live ISO Respins containing post-release updates
Reply With Quote
  #12  
Old 28th May 2017, 09:06 PM
rickhrkachjr Offline
Registered User
 
Join Date: May 2017
Location: United States
Posts: 2
windows_98_nt_2000mozilla
Re: You don't have permission to access /phpmyadmin on this server [FC22 server]

It is a fedora 25 server with the latest MariaDB, php and myadminphp. The problem looked close to what I was having. I have access to myadminphp in local host mode but not over the internet. My web page is available over the internet. Let me get back to my server and I will have a better description of the problem.
Reply With Quote
Reply

Tags
access , fc22 , or phpmyadmin , permission , server

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Error 403 on Apache server, You don't have permission to access / on this server. mothes Servers & Networking 2 16th February 2014 06:52 PM
SVN Server Access Permission??? ajeetraina Servers & Networking 1 27th March 2008 07:44 AM


Current GMT-time: 15:25 (Sunday, 22-10-2017)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat