Fedora Linux Support Community & Resources Center
  #1  
Old 26th February 2006, 02:31 PM
viciouslime Offline
Registered User
 
Join Date: Feb 2006
Posts: 19
Unhappy openoffice.org locked settings...

The language settings show a little padlock next to thm and when you hover over it it says "this setting is protected by the administrator". Tried running as root, same thing happens.

At the moment it is stuck on English (US) i wan't it to be just English/English (UK)...

Anyone else had this problem? I can't find anything ANYWHERE about how to solve it...
Reply With Quote
  #2  
Old 26th February 2006, 03:01 PM
centos_x Offline
Registered User
 
Join Date: Apr 2005
Location: italia
Posts: 157
Is there really that much difference in a computer world never really looked at them, I know in general conversation there is a little difference. With exception to metric system and maybe date format what is the difference.

This is not trying to pick at nationalities it's a legit question, because with exception of few things being called different, (truck)(lorry) things like that everything else is close except some of the backwoods irish, I have hard time understanding some of them........

Last edited by centos_x; 26th February 2006 at 03:03 PM.
Reply With Quote
  #3  
Old 26th February 2006, 03:29 PM
code_astronomer's Avatar
code_astronomer Offline
Registered User
 
Join Date: Dec 2005
Location: England
Posts: 470
Is that under Options->Languages?
Does 'Local setting' say English (UK)?

You should be able to check the box 'For current document only' ... I'll have a look and see if I can find any way of changing it. (I also have the padlocks...bur mine is set as English (UK))
__________________
-- M$ cater for the lowest common denominator --
Reply With Quote
  #4  
Old 26th February 2006, 03:33 PM
code_astronomer's Avatar
code_astronomer Offline
Registered User
 
Join Date: Dec 2005
Location: England
Posts: 470
This is taken from the OpenOffice.org help file:

Quote:
Default languages for documents
Specifies the languages for spellchecking, thesaurus and hyphenation.
Selecting the Document Language


The spellcheck for the selected language only functions when you have installed the corresponding language module. A language entry has a check mark in front of it if the spellcheck is activated for this language.
__________________
-- M$ cater for the lowest common denominator --
Reply With Quote
  #5  
Old 26th February 2006, 05:29 PM
Lluisanunez's Avatar
Lluisanunez Offline
Registered User
 
Join Date: Mar 2005
Location: Barcelona
Posts: 372
I have the same problem, I installed a language package but I only can change the language for the current document, I can't set it as the default language
__________________
registered linux user #317675
Reply With Quote
  #6  
Old 26th February 2006, 05:35 PM
Firewing1's Avatar
Firewing1 Offline
Registered User
 
Join Date: Dec 2004
Location: Canada
Age: 26
Posts: 9,224
Update your OO.o:
Code:
yum update -y
it's a known bug an has been fixed in the newest version. if you don't want to upgrade, a workaround is highlight all text, [menu]Format > Character and set the language.
Firewing1
__________________
[+] My open source software and blog
[+] Some of my howtos: (for full list, click here)
Reply With Quote
  #7  
Old 26th February 2006, 05:58 PM
Lluisanunez's Avatar
Lluisanunez Offline
Registered User
 
Join Date: Mar 2005
Location: Barcelona
Posts: 372
What version is it? I have 2.0 and Yum says nothing to update
__________________
registered linux user #317675
Reply With Quote
  #8  
Old 26th February 2006, 06:33 PM
Firewing1's Avatar
Firewing1 Offline
Registered User
 
Join Date: Dec 2004
Location: Canada
Age: 26
Posts: 9,224
Code:
[admin@FC5T3 ~]$ rpm -qf /usr/bin/openoffice.org-2.0
openoffice.org-core-2.0.1.1-11.2.2
Firewing1
__________________
[+] My open source software and blog
[+] Some of my howtos: (for full list, click here)
Reply With Quote
  #9  
Old 26th February 2006, 06:41 PM
viciouslime Offline
Registered User
 
Join Date: Feb 2006
Posts: 19
Where do we get the updated version from? Yum thinks openoffice.org-core-2.0.1.1-5.1 is the latest.
Reply With Quote
  #10  
Old 26th February 2006, 07:01 PM
Firewing1's Avatar
Firewing1 Offline
Registered User
 
Join Date: Dec 2004
Location: Canada
Age: 26
Posts: 9,224
I'm using FC5T3 -- So a
Code:
su -
yum update openoffice.org-draw openoffice.org-core openoffice.org-calc openoffice.org-writer openoffice.org-impress openoffice.org-base openoffice.org-math --enablerepo=development --enablerepo=extras-development
I'm not sure if this will have the massive dep problem, but that's the new OO.o
Firewing1
__________________
[+] My open source software and blog
[+] Some of my howtos: (for full list, click here)
Reply With Quote
  #11  
Old 26th February 2006, 07:07 PM
viciouslime Offline
Registered User
 
Join Date: Feb 2006
Posts: 19
Ahhh from the devlopement repo. Thanks!
Reply With Quote
  #12  
Old 26th February 2006, 07:15 PM
Firewing1's Avatar
Firewing1 Offline
Registered User
 
Join Date: Dec 2004
Location: Canada
Age: 26
Posts: 9,224
Did it bring in the gazillion other dev packages or did it only update OO.o?
Firewing1
__________________
[+] My open source software and blog
[+] Some of my howtos: (for full list, click here)
Reply With Quote
  #13  
Old 26th February 2006, 07:46 PM
Lluisanunez's Avatar
Lluisanunez Offline
Registered User
 
Join Date: Mar 2005
Location: Barcelona
Posts: 372
ARGHHH!!!
too many dependencies. I guess I'll wait for the upgrade in the usual repos. In the meantime, I've improved your workaround:
In OOwriter, assuming you have installed the language package(s) you want:
1. Open a new document
2. Go to styles and set the fonts with the language of your choice for every style you use
3. Save as default template in your home folder
4. Go to File > New > Documents and Templates > Organize
5. Rightclick on your default template and set 'make it default'. All new documents will be created in the new language

Thanks,
__________________
registered linux user #317675
Reply With Quote
  #14  
Old 26th February 2006, 07:53 PM
Firewing1's Avatar
Firewing1 Offline
Registered User
 
Join Date: Dec 2004
Location: Canada
Age: 26
Posts: 9,224
I think I said it before, but an easier workaround:
Select > All
Format > Character
Choose your language
Firewing1
__________________
[+] My open source software and blog
[+] Some of my howtos: (for full list, click here)
Reply With Quote
Reply

Tags
locked , openofficeorg , settings

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
OpenOffice.org forgets changes to settings mpolo Using Fedora 0 13th August 2005 10:11 AM
OpenOffice locale settings linuxfj Using Fedora 1 27th February 2005 09:54 PM
openoffice.org and mozilla ignore font settings stoty Using Fedora 4 18th August 2004 07:46 PM


Current GMT-time: 15:04 (Wednesday, 18-10-2017)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat