Fedora Linux Support Community & Resources Center
  #1  
Old 10th October 2017, 02:30 PM
forivin Offline
Registered User
 
Join Date: Aug 2017
Location: Earth
Posts: 9
linuxfedorafirefox
Terrible QoS... Searching for updates blocks the Internet for a long time every day.

I set Fedora up to do updates once a day. The problem is that when it starts searching for updates in the background (without a warning or anything), my Internet becomes completely unusable for a long time. It's not just that it's really slow during that time, I actually have trouble sending receiving any packets at all while the update search happens.

But the issue is not just with updates. Actually when I have a download running in Firefox, I can't update anymore and get issues like:

Code:
Error: Error downloading packages:
  Curl error (6): Couldn't resolve host name for https://mirrors.fedoraproject.org/metalink?repo=updates-released-f26&arch=x86_64 [Could not resolve host: mirrors.fedoraproject.org]
Also, I can't browse the Internet anymore during that time, not even in the same browser.

All this just didn't happen when I used Windows 8 and not Fedora.

I assume this is because Windows has some sort of QoS packet prioritization built-in which Fedora lacks, at least by default.

Is there a way to get proper QoS, so that I can use my whole bandwidth, but do multiple things at a time properly?
If not, is there a way to limit the update download speeds?

My Internet is pretty slow btw. Around 450KiB/s.
Also, I have a pfSense router. I think it can do packet prioritization, but I have no clue what I would have to change in order to do downloads/updates and browsing, streaming videos etc at the same time.
Reply With Quote
  #2  
Old 10th October 2017, 10:08 PM
srakitnican Online
Registered User
 
Join Date: Oct 2011
Posts: 1,584
linuxchrome
Re: Terrible QoS... Searching for updates blocks the Internet for a long time every d

QoS filters out traffic based on ports. Traffic that you want to filter uses the same http port. While in theory it could be possible to filter such traffic if sniffing it, there is no way to filter https since it is encrypted. It is possible however to limit the bandwidth for dnf, to lets say 200kb/s, should leave plenty of bandwidth for browsing. I think this option works for dnf-makecache service as well.

/etc/dnf/dnf.conf
Code:
throttle=200k
Don't forget to disable Gnome Software.

Code:
$ gsettings set org.gnome.software download-updates false
Reply With Quote
  #3  
Old 11th October 2017, 12:51 AM
marko's Avatar
marko Offline
Registered User
 
Join Date: Jun 2004
Location: Laurel, MD USA
Posts: 7,131
linuxfedorafirefox
Re: Terrible QoS... Searching for updates blocks the Internet for a long time every d

Some other tips:

if you don't use IPv6, then

1) in your desktop network widget set ipv6 to "ignored" or "disabled"

2) in /etc/dnf/dnf.conf set:

ip_resolve=4

3) in Firefox's "about:config" page set:

network.dns.disableIPv6 true

These together will help Fedora, dnf, and Firefox not waste time on ipv6 connections that don't work.
Reply With Quote
  #4  
Old 11th October 2017, 03:07 PM
forivin Offline
Registered User
 
Join Date: Aug 2017
Location: Earth
Posts: 9
linuxfedorafirefox
Re: Terrible QoS... Searching for updates blocks the Internet for a long time every d

I should mention, I'm using KDE, not Gnome.
I disabled IPv6 and set the throttle as suggested.

So I will at least be able to browse the Internet while the system checks for new updates or downloads them.

But there is still the problem, that while I have an active file download in Firefox, dnf fails and I can't browse the Internet.
Reply With Quote
  #5  
Old 12th October 2017, 01:36 AM
sidebrnz's Avatar
sidebrnz Offline
Registered User
 
Join Date: Oct 2007
Location: Freedonia
Age: 68
Posts: 3,018
linuxfedorafirefox
Re: Terrible QoS... Searching for updates blocks the Internet for a long time every d

I don't know how to solve your issue, but I do know how to get rid of it: don't allow your system to check for updates and/or download them automatically. If this is a home machine, have dnf update your system while you're getting dressed, eating dinner or otherwise not using the computer. If it's a work box, and you control it, have it update while you're getting lunch or otherwise engaged away from your desk, such as in a meeting. That way, you never even see this issue, and it's no longer a problem for you.
__________________
Registered Linux user #470359 and permanently recovered BOFH.

Any advice in this post is worth exactly what you paid for it.
Reply With Quote
  #6  
Old 12th October 2017, 11:29 AM
forivin Offline
Registered User
 
Join Date: Aug 2017
Location: Earth
Posts: 9
linuxfedorafirefox
Re: Terrible QoS... Searching for updates blocks the Internet for a long time every d

I just installed updates and it's still pretty terrible. I was able to browse the Internet without constantly getting "Server not found" errors, but it was extremely slow. A simple Google search took almost 30 seconds even though the updates didn't use the full bandwidth. ... The problem is that the updates now take twice as long because of the throttle. So it's 60 minutes of barely usable Internet vs 30 minutes no Internet. Not really an improvement imo.

Also, when I started a download in Firefox in the middle of the update process, dnf failed again.

@sidebrnz
The problem is that I keep forgetting it, if it doesn't happen automatically and I can almost never find a time where I can really say that I won't need the Internet for the next 30 minutes.
Reply With Quote
  #7  
Old 12th October 2017, 08:32 PM
Ted Lyngmo Offline
Registered User
 
Join Date: Nov 2015
Location: Gothenburg, Sweden
Posts: 17
windows_7chrome
Re: Terrible QoS... Searching for updates blocks the Internet for a long time every d

Not sure if any of these are applicable to your situation but these are some of the things that's happened to me over the years that has resulted in a similar experience (not limited to dnf though).

* ISP problems (DNS and connection drops etc). I started monitoring and could provide more accurate stats than they had. Seemed to help after a while.
* Modem problem (on either side) - have the ISP measure the quality (they can do it remotely).
* A router reached max number of connections (when the kids started with torrents). QoS settings in the router helped for awhile but in the end I bought a newer router.
* A misconfigured webserver opened my server up as an open proxy. Had half China using my ADSL line to watch funny Youtube videos.

Br,
Ted

Last edited by Ted Lyngmo; 13th October 2017 at 08:32 AM. Reason: typo
Reply With Quote
  #8  
Old 16th October 2017, 03:56 PM
forivin Offline
Registered User
 
Join Date: Aug 2017
Location: Earth
Posts: 9
linuxfedorafirefox
Re: Terrible QoS... Searching for updates blocks the Internet for a long time every d

But as I said, I only experience this problem on Fedora. On Windows it worked just fine.
Reply With Quote
  #9  
Old 16th October 2017, 04:25 PM
Ted Lyngmo Offline
Registered User
 
Join Date: Nov 2015
Location: Gothenburg, Sweden
Posts: 17
windows_7chrome
Re: Terrible QoS... Searching for updates blocks the Internet for a long time every d

Quote:
Originally Posted by forivin View Post
But as I said, I only experience this problem on Fedora. On Windows it worked just fine.
I see - so you can run Windows without problems on another machine at the same time as dnf is running on your Linux box? If so, disregard my ideas :-)

Br,
Ted
Reply With Quote
  #10  
Old 17th October 2017, 07:17 AM
marko's Avatar
marko Offline
Registered User
 
Join Date: Jun 2004
Location: Laurel, MD USA
Posts: 7,131
linuxfirefox
Re: Terrible QoS... Searching for updates blocks the Internet for a long time every d

I ran Fedora on much slower DSL (3 Mbit) before I got FIOS at 150 Mbit, and it didn't have this QoS problem.

One thing you might try is,

1) set up the daily dnf updates for a time you're not using it like 3am (cron job or dnf-automatic)
https://fedoraproject.org/wiki/AutoUpdates

that won't be practical if it's a laptop or PC that's off at night

2) do what I do, I disable periodic background updates of the metadata by setting
Code:
metadata_timer_sync = 0
in /etc/dnf/dnf.conf

then I just manually run dnf check-update occasionally. That way the dnf only runs when I run it.
This way any bad network affects of dnf is mostly a moot issue. Sometimes I need to
add --refresh to the command to force an update of package data.

Last edited by marko; 17th October 2017 at 07:24 AM.
Reply With Quote
  #11  
Old 17th October 2017, 09:32 AM
flyingdutchman Offline
Registered User
 
Join Date: Jan 2015
Location: Al Ain, UAE
Posts: 724
linuxfedorafirefox
Re: Terrible QoS... Searching for updates blocks the Internet for a long time every d

Hmm, the age old automatic screw-up debate...

I seldom do updates (only when I have to install a new software package).

Once a year at Christmas time when I feel bored, I completely re-install the system.
__________________
--
Have fun!
http://www.aeronetworks.ca
Reply With Quote
Reply

Tags
blocks , day , internet , long , qos , searching , terrible , time , updates

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Boot time very long after updates and kmods George Ion Using Fedora 22 8th May 2017 06:56 AM
tar -czf taking long long time shariqnitt EOL (End Of Life) Versions 3 31st January 2011 01:17 PM
having terrible time getting IP address for eth0 D_bot Servers & Networking 5 24th December 2009 06:47 PM
Long Time - No Updates Trapper Using Fedora 4 5th September 2008 06:03 PM
Checking for updates / "retrieving software information" taking a very long time. BlackBox222 Using Fedora 4 12th November 2007 01:42 AM


Current GMT-time: 15:15 (Sunday, 22-10-2017)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat