Fedora Linux Support Community & Resources Center
  #1  
Old 31st May 2008, 09:12 AM
betsubetsu Offline
Registered User
 
Join Date: Nov 2004
Location: /dev/zero
Posts: 39
compiz problem: the super key does not work

I installed compiz-fusion and it is working. I can rotate the cube.
But the super key itself does not work.

Super+Tab does not make the ring switcher to work. But I can grab the key combination <Super>Tab in the CCSM Ring Switcher section though.

Adding
Code:
Option      "XkbOptions" "altwin:super_win"
in the InputDevice section of the xorg.conf file has not effect.

Does anyone have a suggestion?
Thanks.
BB

Code:
$ xmodmap 
xmodmap:  up to 4 keys per modifier, (keycodes in parentheses):

shift       Shift_L (0x32),  Shift_R (0x3e)
lock        Caps_Lock (0x42)
control     Control_L (0x25),  Control_R (0x6d)
mod1        Alt_L (0x40),  Meta_L (0x9c)
mod2        Num_Lock (0x4d)
mod3      
mod4        Super_L (0x73),  Super_R (0x74),  Super_L (0x7f),  Hyper_L (0x80)
mod5        Mode_switch (0x5d),  ISO_Level3_Shift (0x71),  ISO_Level3_Shift (0x7c)
xev gives this:
Code:
KeyPress event, serial 28, synthetic NO, window 0x5000001,
    root 0x1a6, subw 0x0, time 3629604, (565,886), root:(573,985),
    state 0x0, keycode 115 (keysym 0xffeb, Super_L), same_screen YES,
    XLookupString gives 0 bytes: 
    XmbLookupString gives 0 bytes: 
    XFilterEvent returns: False

KeyRelease event, serial 31, synthetic NO, window 0x5000001,
    root 0x1a6, subw 0x0, time 3629733, (565,886), root:(573,985),
    state 0x40, keycode 115 (keysym 0xffeb, Super_L), same_screen YES,
    XLookupString gives 0 bytes: 
    XFilterEvent returns: False
Reply With Quote
  #2  
Old 31st May 2008, 09:22 AM
leigh123linux
Guest
 
Posts: n/a
If you use gnome try

Code:
gnome-keyboard-properties

Select the layout tab then layout options / alt win key behaviour and check "super is mapped to the win keys option .
Reply With Quote
  #3  
Old 31st May 2008, 09:31 AM
betsubetsu Offline
Registered User
 
Join Date: Nov 2004
Location: /dev/zero
Posts: 39
yes, it is configured like you said but it has no effect also.
Reply With Quote
  #4  
Old 31st May 2008, 09:47 AM
leigh123linux
Guest
 
Posts: n/a
Quote:
Originally Posted by betsubetsu
yes, it is configured like you said but it has no effect also.

Have you checked the shift switcher to make sure the <Super>Tab binding isn't already allocated to this plugin !


P.S what compiz version are you using ? ( 0.7.5 would normally automatically disable any conflicting key bindings )
Reply With Quote
  #5  
Old 31st May 2008, 11:32 AM
betsubetsu Offline
Registered User
 
Join Date: Nov 2004
Location: /dev/zero
Posts: 39
No the shift switcher uses shift+super+s.

The version i have is 0.7.2, the latest from the repositories.

Last edited by betsubetsu; 31st May 2008 at 11:35 AM.
Reply With Quote
  #6  
Old 31st May 2008, 11:40 AM
scottro Offline
Retired Community Manager -- Banned from Texas by popular demand.
 
Join Date: Sep 2007
Location: NYC
Posts: 8,129
One thing I have noticed, from time to time, in various versions of X (including, possibly FreeBSD) is a sporadic failure with the super key. Although xmodmap will show it, it doesn't seem recognized.

I've gotten around it by creating a $HOME/.xmodmaprc which reads

keycode 115 = Super_L
add Mod4 = Super_L

Then, if I have that issue (in any window manager) I type
xmodmap ~/.xmodmaprc
Then the Super key starts working.
However in my case, it's not a constant issue, so I don't know if that will help.
Reply With Quote
  #7  
Old 31st May 2008, 11:45 AM
betsubetsu Offline
Registered User
 
Join Date: Nov 2004
Location: /dev/zero
Posts: 39
Sorry, this did not help.
Reply With Quote
  #8  
Old 31st May 2008, 11:48 AM
leigh123linux
Guest
 
Posts: n/a
Quote:
Originally Posted by betsubetsu
No the shift switcher uses shift+super+s.

The version i have is 0.7.2, the latest from the repositories.

I seem to remember having similar issues with the 0.7.3 build !
Why don't you try 0.7.5 ( see link in my sig ) ?
Reply With Quote
  #9  
Old 31st May 2008, 11:55 AM
betsubetsu Offline
Registered User
 
Join Date: Nov 2004
Location: /dev/zero
Posts: 39
by the way, I don't know if this is related but it seems that the compiz i have is very minimalist. I can't get the 3D window effect even if selected. Cube reflection also does not work, no reflection.

If i grab a different key combination for the ring switcher for example ctrl-tab, it does not work as well.
Reply With Quote
  #10  
Old 31st May 2008, 11:56 AM
betsubetsu Offline
Registered User
 
Join Date: Nov 2004
Location: /dev/zero
Posts: 39
i will try with 0.7.5
Reply With Quote
  #11  
Old 31st May 2008, 12:11 PM
betsubetsu Offline
Registered User
 
Join Date: Nov 2004
Location: /dev/zero
Posts: 39
funny thing. I open the CCSM from the notification area and the ring switcher was disabled. I select it and after a few seconds, it is deselected automatically.
Reply With Quote
  #12  
Old 31st May 2008, 12:17 PM
leigh123linux
Guest
 
Posts: n/a
Quote:
Originally Posted by betsubetsu
funny thing. I open the CCSM from the notification area and the ring switcher was disabled. I select it and after a few seconds, it is deselected automatically.

Did you delete the old .gconf compiz config files and reboot ?



Code:
rm -rf /home/*/.gconf/apps/compiz
rm -rf /home/*/.gconf/schemas/apps/compiz
Reply With Quote
  #13  
Old 31st May 2008, 12:20 PM
betsubetsu Offline
Registered User
 
Join Date: Nov 2004
Location: /dev/zero
Posts: 39
I can initiate the water effect with the control+super combination so the super key is working. But i still cannot select the following:
ring switcher
shift switcher
group and tab windows
snapping windows
shelf
extra WM actions

3D windows
motion blur
paint fire on screen

....

all these get deselected automatically!
Reply With Quote
  #14  
Old 31st May 2008, 12:29 PM
leigh123linux
Guest
 
Posts: n/a
Quote:
Originally Posted by betsubetsu
I can initiate the water effect with the control+super combination so the super key is working. But i still cannot select the following:
ring switcher
shift switcher
group and tab windows
snapping windows
shelf
extra WM actions

3D windows
motion blur
paint fire on screen

....

all these get deselected automatically!


Ok you might have a old package still installed , also are you using fusion-icon to start the effects ?


post

Code:
rpm -qa |grep compiz
Code:
rpm -qa |grep emerald
Reply With Quote
  #15  
Old 31st May 2008, 12:32 PM
betsubetsu Offline
Registered User
 
Join Date: Nov 2004
Location: /dev/zero
Posts: 39
I rebooted and "Desktop effects could not be enabled"
Reply With Quote
Reply

Tags
compiz, key, problem, super, work

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Strange GNOME compiz problem with AWN - compiz-gtk? jeffers_uk Using Fedora 1 19th March 2009 08:32 PM
Compiz Super Key issue beterhans Using Fedora 1 16th April 2008 04:37 PM
a problem about FC5 when work in xgl+compiz mrhaigui Using Fedora 0 28th January 2007 02:07 PM
FC6: Laptop is super hot and super fast how do I scale my speed DMD EOL (End Of Life) Versions 4 29th October 2006 07:15 PM
Super Dual Box Pro (PS2 controllers to USB) work OK? joltman Hardware & Laptops 0 23rd October 2006 12:02 PM


Current GMT-time: 03:25 (Thursday, 21-09-2017)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat